philkarljo
Nach etlichem Neuinstallieren von SODE funktioniert es jetzt
Quote 0 0
Lars (29Palms)
Hallo Phil,

sorry dass ich dein Post erst jetzt gesehen habe. Wie oben beschrieben handelt es sich auf jeden Fall um ein SODE-Problem.
Also kontrollieren ob SODE wirklich läuft (im Simulator oben auf der Leiste unter Add-Ons > SODE) - gibt es den Eintrag? Welche SODE
Version hast du installiert?
Im Zweifel ein mal SODE neu-installieren mit der frischesten Version von 12bpilot.
Best regards,
Lars
Quote 0 0
philkarljo
Ich habe seit heute genau das gleiche Problem:
Quote 0 0
Lars (29Palms)
Moin Günter,

Danke für den Log! Aus irgendeinem Grund hast du die XML Dateien für Nürnberg
beide aktiviert, ich denke mal das kommt von De- und Reinstallationen dass eine der beiden Dateien nicht gelöscht wurde.
Bitte gehe in "X:\ProgramData\12bPilot\SODE\xml\" und 
benenne "Captain7_29Palms_EDDN_Default.xml" um in "Captain7_29Palms_EDDN_Default.xml.off"

Es kann sein, dass es daran schon liegt. Ich befürchte aber, dass es nach wie vor ein SODE Problem ist, da in dem 
Log auch steht, dass Dateien von anderen Szenerien (ENAT und EDHI) nicht gefunden wurden.
Die einzige Erklärung, die ich dafür hätte (angenommen der Pfad X:\ProgramData\12bPilot\SODE\SimObjects existiert samt allen Unterordnern)
ist, dass SODE mit dem Laufwerk X:\ nicht klar kommt, wie sich ja schon mit dem Fix oben angedeutet hat. Das kann aber nur
Jeffrey von SODE beantworten. 

Funktioniert SODE denn mit anderen Szenerien?
Best regards,
Lars
Quote 0 0
BRH
Hallo Lars,

im Anhang des Posts befindet sich die Log Datei, die der SODE Manager erzeugt.
Die Fehlermeldungen deuten darauf hin, dass bestimmte Verzeichnisse der Nürnberg Scenery nicht gefunden werden, obwohl sie existieren!

MFG Günter
Quote 0 0
Lars (29Palms)
Hallo Günter,

alles klar das war die einzige Instanz unter der mir dieses Problem bekannt war.
Kannst du ein mal den kompletten SODE Log posten?
Best regards,
Lars
Quote 0 0
BRH
Hallo Lars,

das habe ich bereits getan. Leider findet SODE weiterhin nicht die Verzeichnisse und gibt die entsprechenden Fehlermeldungen aus, so wie sie in der Abbildung angezeigt werden.
Die Installation habe ich selbstverständlich mit Admin-Rechten durchgeführt. Auch eine Neuinstallation der Nürnberg-Scenery habe ich durchgeführt, die aber ebenfalls nicht das Problem
beheben konnte.  Werde weiterhin versuchen die Ursache für das Problem zu ermitteln.

Gruß Günter 
Quote 0 0
Lars (29Palms)
Hallo Günter,

das sind doch erst mal gute Neuigkeiten! Auch super der Support von Jeffrey, dem SODE Entwickler!
Das Problem, welches du nun hast kenne ich von älteren Modulversionen. Du hast nun zwar den Platform Manager
aktualisiert, jedoch nicht das eigentliche Modul. 
Daher würde ich dir folgende Vorgehensweise empfehlen:
Den neuesten Installer von der SODE Website herunterladen und installieren. Anschließend den Patch drüberbügeln,
der das WinSxS Problem behebt.

Dann sollte es laufen (hoffentlich) 🙂
Best regards,
Lars
Quote 0 0
BRH
Hallo Lars,

zunächst einmal einen Dank an dich, für deine Bemühungen mich bei der Problemlösung zu unterstützen!!

Das Problem habe ich nun mittlerweile aber selbst beheben können. Es hatte damit zu tun, dass meine Systempartition nicht auf dem Laufwerk "C:\" liegt, sondern auf dem Laufwerk "X:\". Der  SODE Plattform Manager kennt aber nur eine Systempartition, die angeblich immer nur auf dem Laufwerk "C:\" liegt, was aber nicht immer der Realität entspricht. Der Programmierer von SODE hat den Programmcode nun dahingehend  abgeändert, dass der Plattform Manger auch andere Partitionen darauf untersucht, ob dort eine Systempartition mit dem Unterverzeichnis WinSxS existiert. Nähere Angaben findet man in diesem Link:  https://sode.12bpilot.ch/?topic=winsxs-folder-not-found-p3d-v4. Dort findet man auch einen Link über dem die ausführbare Datei des SODE Plattform Managers als aktualisierte Version neu heruntergeladen werden kann. Das sollte man aber nur dann tun wenn man dieses Problem hat. Installiert man diese Datei, dann wird das Verzeichnis WinSxS nun auch vom SODE Plattform Manager gefunden.

Nach dem der SODE Plattform Manager nun das Verzeichnis finden kann tritt bei mir nun aber ein neues Problem auf. Bestimmte Verzeichnisse von Add Ons können vom SODE Plattform Manager angeblich nicht gefunden werden, obwohl diese ordnungsgemäß installiert sind. Die Abbildung zeigt einen Auszug aus dem Logfile des SODE Plattform Managers, um das Problem zu verdeutlichen:
Fehlermeldungen fehlende Verzeichnisse.png 

Auch eine Neuinstallation der Scenery Nürnberg brachte keine Besserung.  Vielleicht kann ich hier im Forum noch einen Hinweis bekommen, wie ich dieses Problem nun lösen kann.

MfG Günter

Quote 0 0
Lars (29Palms)
Hallo Günter,

der WinSxS Ordner sollte sich unter "C:\Windows\WinSxS" befinden. Der Ordner bedeutet so viel wie "Windows Side by Side" und enthält 
Komponenten, wie dlls, die sich Programme teilen.
Dass dieser bei dir nicht existieren soll (bitte nachprüfen) kann ein großes Problem für das ganze System darstellen.
Wenn der Ordner nicht existiert, und du mit anderen Programmen keine Probleme hast, würde ich den Ordner einfach neu erstellen
und es mit einer erneuten SODE Installation probieren.

Zudem kannst du noch ein mal den SimConnect Installer laufen lassen. Diesen findest du unter
"Prepar3D v4\redist\Interface\FSX-SP2-XPACK\retail\lib"
Best regards,
Lars
Quote 0 0
BRH
Hallo Lars,

Auch nach einer Neuinstallation von SODE tritt der Fehler auf bzw. befinden sich rot markierte Kreuze auf dem Airportgelände. Zudem meldet SODE, dass es ein bestimmtes Verzeichnis nicht finden kann, siehe bitte Abbildung. Wie kann ich SODE mitteilen wo dieses Verzeichnis liegt? Gibt es irgendeine Konfigurationsdatei von SODE in die ich den Pfad eintragen kann? 
NoVerzeichnis.png 

Mit freundlichen Grüßen
Günter
Quote 0 0
Lars (29Palms)
Hallo Günter,

die roten Kreuze bedeuten, dass SODE installiert ist aber die Szenerieobjekte nicht finden kann.
Das passiert mit älteren Versionen von SODE. Bitte de-installiere SODE und installiere die aktuellste Version,
um schon mal sicherzugehen: https://sode.12bpilot.ch/?page_id=9
Best regards,
Lars
Quote 0 0
BRH
Hallo Leute,
auch bei mir fehlen viele Objekte!

Ich habe mir gestern über den Shop von Aerosoft die Scenery Nürnberg von 29Palms für den Flugsimulator Prepare3D v4 zugelegt. Nach der Installation wird mir der Flughafen nicht vollständig angezeigt.
Zudem stehen viele rote Kreuze auf dem Flughafengelände herum (siehe Abbildung). So etwas habe ich noch nicht erlebt.
Wahrscheinlich handelt es sich um ein Aktivierungsproblem, obwohl man zum Start der Installation keinen Aktivierungscode eingeben musste.
Habe im Übrigen die Installation mit Admin Rechten gestartet. SODE ist übrigens bei mir installiert!
Abbildung zu EDDN.png 
Ich hoffe, dass mir jemand einen sachkundigen Rat geben kann, wie ich das Problem beheben kann bzw. welche Ursache der Erscheinung überhaupt zugrunde liegt.
Kenne mich zudem mit dem Prepare3D v4 Simulator noch nicht so gut aus.

MfG Günter
Quote 0 0
Captain7

Hallo

Habe das exakt gleiche Problem

mfg



Dann gilt die gleiche Antwort: Bitte die SODE Installation prüfen.

Grüße Volker
Quote 0 0
Stefan Binder

Hallo

Habe das exakt gleiche Problem

mfg

Quote 0 0
VIEspotting
OK, Vielen Dank
Quote 0 0
Lars (29Palms)
Das sollte nicht nötig sein, einfach Testen ob die Gebäude erscheinen.
SimConnect sollte ebenfalls installiert sein, damit SODE mit dem Flugsimulator kommunizieren kann. Im Zweifel kannst du den SimConnect Installer einfach ausführen. Diesen findest du hier: "Prepar3D v4\redist\Interface\FSX-SP2-XPACK\retail\lib"
Best regards,
Lars
Quote 0 0
VIEspotting
Ich habe SODE jetzt neu installiert, soll ich Nürnberg auch neu installieren?
Quote 0 0
Captain7
Hallo Thomas,

das Fehlerbild deutet auf ein nicht richtig installiertes oder aktiviertes SODE Modul hin. 

Das bitte einmal prüfen und Sode ggfs. neu installieren. Siehe auch https://sode.12bpilot.ch/?topic=troubleshoot-guide
 
Grüße Volker
Quote 0 0
VIEspotting
Hallo,

Ich habe mich echt sehr gefreut als endlich der neue Airport draußen war, hab ihn auch gleich installiert aber es fehlen leider die Bodentexturen und Terminals.

Würde mich sehr über eine Antwort freuen.

ps: habe auch ORBX Global Base Pack

MFG Thomas
Quote 0 0