Adam Kennedy
Thank you very much! I was concerened since a lot of pre-2015 aerosoft stuff isn't FSX:SE compatible due to the vistimare module (I think it's called that) but it's fantastic news to hear yours are compatible... I am partial to European charter flying on FSX and Skiathos and Mykonos will be perfect new destinations, and they both look outstanding! 

Thank you very much! 
Quote 0 0
Lars (29Palms)
Hi Adam,

thanks for considering the purchase! They are compatible with FSX:SE but I'm not sure if the installer lets you point to the correct directory. If not you have to instruct it to install into your FSX:SE root directory. 
I will be happy to assist if you're facing problems which can be solved for sure!
Best regards,
Lars
Quote 0 0
Adam Kennedy
Hello!
I would really like to know, before I buy, if your older products (specifically Mykonos and Skiathos) are compatible with FSX:SE. I know 99% of addons are, but considering they are sold by Aerosoft, I thought it best to ask. [smile]

Thanks, Adam 
Quote 0 0