Lars (29Palms)
Thank you for reporting this!
It is strange, the logic behind it is EXACTLY the same for the Prepar3D v4 version. I will compile a new installer and can send you a link for verification that it's working for you.
If you are interested, please send an e-mail to contact[at] 29palms.de
Best regards,
Lars
Quote 0 0
atcogl
Just want to add another data point, I have this exact same issue installing today using the latest installer downloaded from Aerosoft.

After the installer completes a small screen pops up saying the application can only be run by an installer and that this application will now close. Installer was run as Administrator. Tried installing into root V5 directory and also folder outside root and same issue each time.
Used the zip below however to add the scenery to P3D.
Quote 0 0
Lars (29Palms)
Thank you for providing the steps and letting me know guys!

I must admit I don't know why the AddScenery tool doesn't "fire" for you guys since I have tested it several times.
I will make sure to get to the bottom of this and provide a new version of the installer with the tool working
Best regards,
Lars
Quote 0 0
ProfessorMadman
Hi, yes I've managed to use the ZIP that Lars attached earlier in this thread and modified it to point to my install path and it's all working.  Just figured I'd let Lars know that there may be a problem with the installer as it errored on me both with installing into P3Dv5 and outside of it.
Quote 1 0
k4cz0rca
Hey ProfessorMadman.
So sound like u installed and u dont have it in P3D.
Here is solution.
Make a Xml file in Skiathos folder and past it.

<?xml version="1.0" encoding="utf-8"?>
<SimBase.Document Type="AddOnXml" version="4,0" id="add-on">
<AddOn.Name>29Palms - LGSK - Skiathos</AddOn.Name>
<AddOn.Description>29Palms Skiathos Airport for Prepar3D</AddOn.Description>
<AddOn.Component>
<Name>29Palms - LGSK - Skiathos</Name>
<Category>Scenery</Category>
<Path>F:\29Palms\29Palms - LGSK - Skiathos\scenery</Path>
</AddOn.Component>
<AddOn.Component>
<Category>Texture</Category>
<Path>texture</Path>
</AddOn.Component>
<AddOn.Component>
<Category>Effects</Category>
<Path>effects</Path>
</AddOn.Component>
<AddOn.Component>
<Category>Sound</Category>
<Path>sound</Path>
</AddOn.Component>
<AddOn.Component>
<Category>Autogen</Category>
<Path>autogen</Path>
</AddOn.Component>
</SimBase.Document>


MAKE SURE U CHANGE THIS TO UR PATH  (<Path>F:\29Palms\29Palms - LGSK - Skiathos\scenery</Path>)-SO UR MAYBE IS D DRIVE OR WHATEVER.
Then open C:\Users\YOUR USER NAME\AppData\Roaming\Lockheed Martin\Prepar3D v5  Addons.cfg
Put this in to ur file:
[Package.3]  -----change if needed to any nymber 0.1.2.4.5. etc
PATH=F:\29Palms\29Palms - LGSK - Skiathos  -its need to be path where Skiathos is installed.
ACTIVE=true
REQUIRED=false
Save the file and start P3D. Enjoy
BTW😃o u have folder Libraries from 29 Palms?If yes u need to do same steps as above.
Quote 0 0
ProfessorMadman
Hi Lars,

Same issue here - fresh PC build with only P3Dv5.  The configurator kicks an error about adding the scenery to the sim.  I checked the log and it's looking for an XML file named ts.xml which is not in the location pointed in the log...

020-04-19-16:46:16.8191 - TNPTroubleshooting::initializeAddOns => Exception: Message -> Could not find file 'D:\Prepar3D v5 3rd Party Sceneries\29Palms\29Palms - Configurator\scripts\ts.xml'.


In my D:\Prepar3D v5 3rd Party Sceneries\29Palms\29Palms - Configurator\scripts folder I only have:

Directory of D:\Prepar3D v5 3rd Party Sceneries\29Palms\29Palms - Configurator\scripts

19/04/2020 16:46 <DIR> .
19/04/2020 16:46 <DIR> ..
13/04/2020 10:18 138 config_29PLib.xml
13/04/2020 15:30 6,186 config_LGSK.xml
19/04/2020 16:46 261 home.xml
19/04/2020 16:46 <DIR> temp
3 File(s) 6,585 bytes

Directory of D:\Prepar3D v5 3rd Party Sceneries\29Palms\29Palms - Configurator\scripts\temp

19/04/2020 16:46 <DIR> .
19/04/2020 16:46 <DIR> ..
0 File(s) 0 bytes

Total Files Listed:
34 File(s) 15,003,543 bytes


Regards,
Daniel
Quote 0 0
thenikos
thank you, everything worked fine like that 🙂
Quote 0 0
Lars (29Palms)
Almost 🙂

Create a folder "29Palms - LGSK - Skiathos" like the other folders and just move the add-on.xml into that new folder
Best regards,
Lars
Quote 0 0
thenikos
hi, i did that, but something strange happened (i think 🙂 ) : the add-on.xml remained in the prepar3d add-ons folder and it didn't create a 29palms-lgsk-skiathos folder, with files inside as the samos did.
i attach photos. is it ok like that?
thanks
Quote 0 0
Lars (29Palms)
Thanks! The tool which is supposed to add the scenery to your library did not run. Maybe it had been blocked for some reason,
although it is strange since LGSM got added fine which uses the same tool.

Anyway, please extract the following archive to your "Documents/Prepar3D v5 Add-Ons" folder, this should register
Skiathos properly with your simulator
Best regards,
Lars
Quote 0 0
thenikos
i have just sent it, thank you
Quote 0 0
Lars (29Palms)
Strange, this is the first time I'm not getting those e-mails!

Anyway, you can sent the following files to contact[at] 29palms.de :

Go to your Prepar3D v5 folder and open "29Palms/29Palms - Configurator", zip the "logs" folder and send it over

Also tell me the full path to your Prepar3D v5 folder so I can create the add-on.xml for Skiathos for you.

Thanks in advance 🙂
Best regards,
Lars
Quote 0 0
thenikos
hi, sent it again, i got the message "message sent" both times. i hope you got it now. otherwise just tell me to send you the files in a regular email. thank you 🙂
Quote 0 0
Lars (29Palms)
Hi it looks like the mail didn't get through, can you try again?
If that doesn't work I will send you instructions on which files to send over
Best regards,
Lars
Quote 0 0
thenikos
thanks for your answer. i have sent you the email
Quote 0 0
Lars (29Palms)
Hi there,

please send an e-mail using the Configurator so I can see the logs.
Click on the paperplane icon in the upper right corner and on the dialog select "Attach Simulator Files"

After that I can also send you the correct file for registering Skiathos.
The P3D5 version does not require the ACM anymore
Best regards,
Lars
Quote 0 0
thenikos
hi, i tried to installed the skiathos 1.51 to p3d v5 but something goes ... wrong:
i run the installer as administrator, everything finish fine, but the skiathos scenery is not added automatically in p3d scenery.
(samos on the other hand, following the same procedure, installs just fine).
i also notice, that there should also be the autogen configurator merger. but also that programm is not installed.
do you think that causes the problem?
if i add skiathos by hand in scenery, will it work fine? even without the autogen configurator?
thank you
Quote 0 0